[TI] Speed

Discussion in 'General Archive' started by ♥«Fūяÿš•Řєvєηgє»♥, May 19, 2017.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. Either my ship is broke or the game is again. I am in spectrum and my speed is 432 and yes I do have prom on my speed gens. Why new problems every day?! Also is chat fixed yet because there is nothing new in forums????
     
  2. neoonoma

    neoonoma Forum Expert

    How many speed gens do you have at ship?You should have 433 speed with 8 if all of them are G-7900
     
  3. ok maybe I am wrong idk this game has been messed up all week. I have all speed gens and prom on and am going 432.
     
  4. max speed should be 450 but yet still no help typical............
     
  5. HelpMeHelpYou

    HelpMeHelpYou Forum Freak

    A little patience goes a long way on the forums. We need more information from you to do the proper calculations, number and type of speed gens assigned.

    Base speed is 300 + 15 G7900 Generators (150) + Prom boost (20% * 150) = 480
     
  6. Again I have all speed Gens on config 1 I am only going 423 and I have prom on. Config 2 I am going 288. I know what speed should be but it is only going 423 which means something is wrong and btw I have been waiting all day and also see others that have posted after me have been answered..

    432 my bad. Still not going what it should.

    OK I unequipped my speed gens and reequipped it has fixed the problem ty
     
    Last edited by moderator: May 19, 2017
  7. Deter

    Deter User Team Darkorbit

    Closing as resolved,

    Take Care.
     
Thread Status:
Not open for further replies.

Share This Page