1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

crafting quests

Discussion in 'Quests' started by sohcim, Dec 21, 2018.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. sohcim

    sohcim Forum-Greenhorn

    hello!i guess its not just me or maybe it is,but i cannot make any progress with the quests required to learn crafting..i'm stuck on the quest that needs 60 bones and not only that,its a repeatable one..just so you know my toon is 48lvl,and being able to make only simple gems is quite frustrating!can someone please guide me through this?
     
  2. Novadude

    Novadude Commander of the Forum

    you can always skip the repeatable quest and go to the next city (Resistance command center, most likely for you) and pick up the next master of disaster quest.
     
  3. jelbeat

    jelbeat Someday Author

    Well i'm stuck in Jarlhofn. Did the quest to show a polished gem (4/9) and there are no new cratfing queste anymore.
    At least, i couldn't find any. Been to every city in each region, but there aro no more green exclamation marks to be found, only the repeatable ones. But quest 4/9 means 5 more quests to go.
    Anyone knows where to find these?
     
  4. ΣMiwel

    ΣMiwel Forum Baron

    Ashraya.
    Take a look at the bottom of the screen when standing next to the travel stone.
     
  5. _Baragain_

    _Baragain_ Living Forum Legend

  6. jelbeat

    jelbeat Someday Author

    Went to Ashraya and found it, no idea why i didn't see it the first time.
    Did look for it on Wikia, couldn't find it there either.
    Guess it was not my "finding" day.
    Thnxx both for ur help.
     
  7. euuu79

    euuu79 Forum-Greenhorn

    i have a problem ...i can not craft the gems though i have researched them
     
  8. _Baragain_

    _Baragain_ Living Forum Legend

    The quest line is 9 parts. What is the highest part have you've completed?
     
  9. ijzerreus

    ijzerreus Forum-Apprentice

    I am currently doing the first of the crafting quest and i encounter the next problem:

    [​IMG]

    [​IMG]

    As you can see i have the Anacampseros but Petyax won't recognise them.
    I did buy a bottle but that didn't change it.

    I also have deleted the quest and accepted it again but got the same problem.
     
  10. trakilaki

    trakilaki Living Forum Legend

    Have you tried with more Anacampseros?
    If not ... try to get few more and see if it helps.
     
  11. MikeyMetro

    MikeyMetro Forum Overlooker

    Two questions: What level is your toon and where did you get your Camperweed? One thing I have found doing this quest with some of my lower level Alts is that you must do this first quest in PoS.
     
  12. ΣMiwel

    ΣMiwel Forum Baron

    Have you read the objective? Travel to any Duria dungeon[...] So, just travel to any Duria dungeon (Slifmoor+Shorefolk... or simply everything before the RCC+Stonekeep), and he'll accept the quest from you. Or just turn the quest navigation on and go to any dungeon it leads you to.
    It was that way in TS (or rather, you had to enter PoS for the first objective - read above). If I remember correctly, it worked with all the Duria (but not Teganswall) dungeons as soon as the R214 went live.
     
  13. MikeyMetro

    MikeyMetro Forum Overlooker

    Like I said I am currently doing this with older alts, 45 and below, on Tegan and this is the only way it works reliably. I have tried other Duria dungeons prior to Teganswall area (Loxley, Stonekeep, FBI) and it does not always work. It might work in LL also but since that is essentially the same run as PoS I have not tried it.

    Since I have 40 some alts to get back to being able to craft the stuff they used to before this patch I am sticking with what works every time ;)
     
  14. ijzerreus

    ijzerreus Forum-Apprentice

    Went to the FBI on painful and did harvest two more Anacampseros and went back to Petyax.
    Unfortunately he still didn't find it enough to finish this part of the quest.
    Have no idea how to solve this.

    Did do this same quest with two other toons in FBI on painful and that was not a problem.
     
  15. Zoltan

    Zoltan Junior Expert

    FBI is a Teganswall dungeon NOT a Duria dungeon. Try Prison of Souls or Eternal watch and you will have more success. Quest requirements says gather from Duria dungeon. I would go with Prison of Souls to be safe given comment by Mikey
     
  16. ΣMiwel

    ΣMiwel Forum Baron

    Rather Eternal Grove. Eternal Watch is Norselands.
     
  17. heror

    heror Forum Baron

    Or even stonekeep its a duria dungeon
     
  18. Dragonnns

    Dragonnns Board Veteran

    When I turned on Quest Guidance, it specifically sent me to Prison of Souls. Give that one a go.
     
  19. MikeyMetro

    MikeyMetro Forum Overlooker

    A bit off-top but perhaps the mod team would pass this on to the devs since the current lot do not seem to know the lore of this game so mayhaps they can get their quest description right :rolleyes:

    Duria is King Harold's realm and includes everything up to pve Herald. Originally the term used to infer the human realm which included the Norselands. This is the way it was even after the introduction of the realms of Atlantis, Myrdosch, and Lor'Tac. But then The term Dracania was introduced to denote the whole world and those feisty Norse dudes and dudettes finally got out from under the thumb of Duria (though they are still part of the alliance.)

    Still, The whole Teganswall area is part of Duria. Which is why Prince Bloody Eye Socket is in RCC trying to get it back :cool:
     
  20. Zoltan

    Zoltan Junior Expert

    Thanks ΣMiwel :) I got mine running stonekeep when release first came out
     

Share This Page