1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

failed to download critical file

Discussion in 'Technical Support' started by unseen94, Sep 13, 2019.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
  1. unseen94

    unseen94 Forum-Greenhorn

    i try to do the tutorial but when i do the first quest the game freeze and it says that i havent download a critical file and when i close the the message the game close too! what can i do to fix that?
     
    Zardast and karpouzokefalos like this.
  2. Sunlight

    Sunlight Board Administrator Team Drakensang Online

    Hey there @unseen94 ,

    Welcome to the EN Forum :)
    First of all, try to clean your temp files folder. Check here how to do it. This should fix.
    Otherwise, try this procedure.
    Let us know if the problem remains.
     
  3. hunter_skull

    hunter_skull Junior Expert

    hi all
    I have the same problem 3 hours now and I cant do anything....
    I try all of this tricks but nothing...
     
    Zardast likes this.
  4. Zardast

    Zardast Forum-Apprentice

    Same problem for the last two days and cannot fix it. I followed all the instructions from the support (update drivers, uninstall, clear dso folder, restart pc etc) but the problem remains:''Error: Failed to downlad a critical file / Failed downloading a critical file (HTTP response error)! '' and other stuff in the text (incomprehensible to me).
    I noticed that when i start the client only the thinclient.exe appears in the task manager (as intended I suppose) but when i start the game and reopen the task manager i see both thinclient.exe and dro_client.exe and sooner or later the error box shows up and the game stops.
    It is really annoying and now in the forum i see I am not the only one.
    Why on earth I see 2 clients in the task manager ?
     
  5. trakilaki

    trakilaki Living Forum Legend

    Don't delete the files ... it is most probably CDN failure.
    Your best chance is to start the game in browser so the files would download.
    If that doesn't help log in to another server (not test server) and see if the game download files there.
     
  6. Darkmae

    Darkmae Forum-Apprentice

    same problem i have..from yesterday.i clean temp ,unistall game 10 times nothing.i flushdns nothing. i delete java files ..clean history..i try to play by browser i play 1 min and the the same fault. havent download a critical file.i try to log in on grimmag i thing there is a problem i cant log in now to test if game plays.i see on youtube someone say 3 steps to fix it..1 step is to dns adress 8.8.8.8.8/8.8.4.4..i dont know what this is if anyone can help.the other steps is clean temp and download the game again..i loose karabossa event.i was 1000 progres to finished and i cant play yestarday all day.

    i dont know what to do to fix this or its time just to leave this... game.

    i play heredur.its happens to all servers i see.
     
    Last edited: Sep 14, 2019
  7. Sunlight

    Sunlight Board Administrator Team Drakensang Online

    Hey there people,

    So, it's a general problem affecting many players :( Can you please tell us which server you play in?
    For now, once my suggestions haven't worked, as @trakilaki already suggested, try to play via Internet Explorer.
    We'll pass this issue to the development team and we are sorry for any inconvenience caused.
    Cheers.
     
  8. Zardast

    Zardast Forum-Apprentice

    Server: HEREDUR

    It seems i have finally fixed it for now by changing DNS address to 1.1.1.1/1.0.0.1 as suggested somewhere (another suggested change to 8.8.8.8/8.8.4.4 by this guy www.youtube.com/watch?v=Ba7hg902S70 did not work).
    I have been playing for about 2 hours straight without problem.
    Still i see 2 clients in the task manager :https://imgur.com/a/TfH1TYk which seems odd but the game works so far and a friend who did not have this issue at all also told me that he sees 2 clients in the task manager from time to time , so I dont know about that.

    [​IMG]

    ----------- MERGED ------------

    Status update: This is not a solid fix, I still get the error but only every 2 hours of playing and only once; after I relog i can play for another 2 hours etc. It happened 3 times just after I entered an anniversary map ( atlantis inf3, normal inf3 and another one). At least I can play now if you can call this a satisfying gaming experience.... In between I might get some nebulas which make me very happy now when I see them :p:p:p:confused::mad:o_O:p
     
    Last edited: Sep 16, 2019
  9. ShortFuseLiakos

    ShortFuseLiakos Forum-Greenhorn

    Hi I have the same problem , I reported it in support too.

    Please help us get a fix we want to play the game . I have 1 Sunday to rest and play and I can't play :(
     
    Last edited: Sep 15, 2019
  10. Goomessd

    Goomessd Forum-Greenhorn

    Hi guys,

    The same problem here, 4 days now and i cant play.
    I reported it in support, but i dont take a feedback.
     
  11. Javah

    Javah Regular

    I do not see how different DNS would ever fix a such issue, unless those you are using are unreliable for themselves.

    Try to do as trakilaki suggested above or, using the client, be sure that it completely downloaded all the files before to start the game. I receive this error message rarely and mostly after release upgrade, if i start the client while download is still in progress.
     
    trakilaki likes this.
  12. ale3androsrafail

    ale3androsrafail Forum-Greenhorn

    hello good evening i have the same problem with my warrior character i can log in on dwarf and its fine but when i try to log in on my war before 2 hours ago this warning appear https://prnt.sc/p6in1s pls fix this thank you.. it says Failed to download critical File...
     
  13. trakilaki

    trakilaki Living Forum Legend

    Folks here is the file you couldn't download (I couldn't see more files in the screenshot above).
    The file is clean and not infected by a virus ... Chuck Norris approved.
    Download it ... unpack it and place the file inside DSOClient folder.
     
    ShortFuseLiakos and Javah like this.
  14. Javah

    Javah Regular

    A further thing, which I did not write about because I did it weeks days ago and then I had forgotten it.

    Starting with Windows 10 build 16232, controlled folder access is introduced in Windows Defender Antivirus. This means that access to the work folder is forbidden to all those software that Microsoft does not automatically consider friendly (its owns) and therefore a notification is produced that warns that the system has prevented changes by the application (but most of users just ignore it).

    Maybe it won't solve your issue, but anyway I'd recommend adding DSO (both thinclient.exe and dro_client.exe) to Windows Defender exceptions, and then try playing again.

    For those who did not know it, dro_client.exe is placed in \Users\%username%\AppData\Local\Temp\DSOClient\dlcache

    Thanks. I downloaded it and put it in DSOClient folder... where it actually wasn't, although I dont remind to have seen any error in this regard. Who knows how many other files I still miss...
     
    Last edited: Sep 16, 2019
    trakilaki likes this.
  15. ShortFuseLiakos

    ShortFuseLiakos Forum-Greenhorn

    Thanks you are the best. I can play normaly now. I will update here if something happens again
     
    trakilaki likes this.
  16. trakilaki

    trakilaki Living Forum Legend

    It is not a first time I am doing this :) http://www.bigpoint.com/drasaonline...o-download-a-critical-file.76804/#post-698220
    I am keeping all files on my PC and making backups frequently. So far I have something like less than 20GB of data XD
     
  17. ale3androsrafail

    ale3androsrafail Forum-Greenhorn

    hello good afternoon can someone explain me why this warning https://prnt.sc/p6swx0 appears all the time when i try to log in on my characters dwarf and war on heredur server on cardhun city please help me fix this... thank you


    --- MERGED ---


    Honestly i deleted all drakensang client files and redownload them from the side 3x times and still this warning appears https://prnt.sc/p6swx0 whats going on can someone pls tell me thank you
     
    Last edited by moderator: Sep 16, 2019
  18. Sunlight

    Sunlight Board Administrator Team Drakensang Online

    Hey there heroes,

    Rest assured that we are reporting this issue.
    For now, you have two options:
    1. Download the missing file that @trakilaki posted above (I forgot to mention that this issue happened some months ago and this procedure worked in my case) :)
    2. Or... you'll have to wait for a hotfix in near future.
    Cheers.
     
  19. Babis3891

    Babis3891 Forum-Greenhorn

    its...already the 3rd day that we cannnot play because of the "Failed downloading a critical file (HTTP response error)....HttpStatus = 410Desc=....etc etc ..Administration says ...that technisians will solve the problem ...On the other hand Seweres event is coming , gamers are collecting keys ..and we are watching videos on YT ..how to farm the keys from rats ....PS : ...premium and deluxe periods are running even is unable to connect in game ....
    Server : Grimmag
     
    Last edited: Sep 17, 2019

Share This Page